An issue was discovered in the libpulse-binding crate before 2.5.0 for Rust.
Priority LOW 31CWE-416Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in the libpulse-binding crate before 2.5.0 for Rust. proplist::Iterator can cause a use-after-free.
Why it matters now
EPSS 0.01001 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed libpulse-binding (crates.io): 2.5.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | libpulse-binding (crates.io) | 1.0.5 to before 2.5.0 | 2.5.0 | Patch available | GHSA-f56g-chqp-22m9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- libpulse-binding (crates.io) Vendor— Affected 1.0.5 to before 2.5.0 Fixed in 2.5.0 Patch available GHSA-f56g-chqp-22m9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpulse-binding_project:libpulse-binding:*:*:*:*:*:*:*:* | 1.0.5 to before 2.5.0 | Vulnerable | Libpulse-binding Project |
- cpe:2.3:a:libpulse-binding_project:libpulse-binding:*:*:*:*:*:*:*:* Versions 1.0.5 to before 2.5.0 Vulnerable ·Libpulse-binding Project
Remediation
- Fix · GHSA-f56g-chqp-22m9 libpulse-binding (crates.io) Fixed in 2.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25001
- 2026-10-03 Alias added: GHSA-f56g-chqp-22m9
References
More Libpulse-binding Project Libpulse-binding vulnerabilities
- TI-2018-15254 An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust. CVSS 3.1HIGH 7.5
- TI-2019-15195 An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. CVSS 3.1HIGH 7.5
- TI-2018-15255 An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust. CVSS 3.1HIGH 7.5
Sources
- CVE-2018-25001 · CVE Program
- CVE-2018-25001 · NVD
- FIRST EPSS
- GHSA-f56g-chqp-22m9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences