An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust.
Priority LOW 36CWE-416Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-416 and the CVSS impact.
Summary
An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust. get_format_info can cause a use-after-free.
Why it matters now
EPSS 0.01413 72nd percentileScored 2026-11-07
Fix Fixed libpulse-binding (crates.io): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | libpulse-binding (crates.io) | before 1.2.1 | 1.2.1 | Patch available | GHSA-hxjf-h2mh-r6hj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- libpulse-binding (crates.io) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-hxjf-h2mh-r6hj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpulse-binding_project:libpulse-binding:*:*:*:*:*:rust:*:* | before 1.2.1 | Vulnerable | Libpulse-binding Project |
- cpe:2.3:a:libpulse-binding_project:libpulse-binding:*:*:*:*:*:rust:*:* Versions before 1.2.1 Vulnerable ·Libpulse-binding Project
Remediation
- Fix · GHSA-hxjf-h2mh-r6hj libpulse-binding (crates.io) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25027
- 2026-10-03 Alias added: GHSA-hxjf-h2mh-r6hj
References
Advisory 3
More Libpulse-binding Project Libpulse-binding vulnerabilities
- TI-2019-15195 An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. CVSS 3.1HIGH 7.5
- TI-2018-15255 An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust. CVSS 3.1HIGH 7.5
- TI-2018-15231 An issue was discovered in the libpulse-binding crate before 2.5.0 for Rust. CVSS 3.1MEDIUM 6.5
Sources
- CVE-2018-25027 · CVE Program
- CVE-2018-25027 · NVD
- FIRST EPSS
- GHSA-hxjf-h2mh-r6hj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences