Read the docs

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285)…

Priority MEDIUM 44CWE-732Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Partial Red Hat: 6 fixed, 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

Why it matters now

EPSS 0.02668 85th percentileScored 2026-11-07
Fix Partial mercurial (PyPI): 4.5.1Red Hat: 1 advisoryRed Hat: 6 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mercurial (PyPI)before 4.5.14.5.1Patch availableGHSA-4mr4-7vjv-9hm6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mercurial (PyPI) Vendor— Affected before 4.5.1 Fixed in 4.5.1 Patch available GHSA-4mr4-7vjv-9hm6

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:*before 4.5.1VulnerableMercurial
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* Versions before 4.5.1 Vulnerable ·Mercurial
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-4mr4-7vjv-9hm6 mercurial (PyPI) Fixed in 4.5.1 Advisory →

Red Hat 1 advisory

  • RHSA-2019:2276 Released 2019-08-06 · Red Hat rating Moderate
    mercurial security update
    • Red Hat Enterprise Linux Client Optional (v. 7) emacs-mercurial-2.6.2-10.el7, emacs-mercurial-el-2.6.2-10.el7, mercurial-2.6.2-10.el7 +1
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) emacs-mercurial-2.6.2-10.el7, emacs-mercurial-el-2.6.2-10.el7, mercurial-2.6.2-10.el7 +1
    • Red Hat Enterprise Linux Server (v. 7) mercurial-2.6.2-10.el7
    • Red Hat Enterprise Linux Server Optional (v. 7) emacs-mercurial-2.6.2-10.el7, emacs-mercurial-el-2.6.2-10.el7, mercurial-hgk-2.6.2-10.el7
    • Red Hat Enterprise Linux Workstation (v. 7) mercurial-2.6.2-10.el7
    • Red Hat Enterprise Linux Workstation Optional (v. 7) emacs-mercurial-2.6.2-10.el7, emacs-mercurial-el-2.6.2-10.el7, mercurial-hgk-2.6.2-10.el7

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2019:2276
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2019:2276
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2019:2276
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2019:2276
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2019:2276
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2019:2276
Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000132
  2. 2026-10-03 Alias added: GHSA-4mr4-7vjv-9hm6

References

Sources