Read the docs

A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in…

Priority LOW 25CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in VSphere.java that disables SSL/TLS certificate validation by default.

Why it matters now

EPSS 0.00417 36th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:vsphere-cloud (Maven): 2.17

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins:vsphere-cloud (Maven)before 2.172.17Patch availableGHSA-vq7p-f4fv-rr5x
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:vsphere-cloud (Maven) Vendor— Affected before 2.17 Fixed in 2.17 Patch available GHSA-vq7p-f4fv-rr5x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:vsphere:*:*:*:*:*:jenkins:*:*up to 2.16VulnerableJenkins
  • cpe:2.3:a:jenkins:vsphere:*:*:*:*:*:jenkins:*:* Versions up to 2.16 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-vq7p-f4fv-rr5x org.jenkins-ci.plugins:vsphere-cloud (Maven) Fixed in 2.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000151
  2. 2026-10-03 Alias added: GHSA-vq7p-f4fv-rr5x

References

  • TI-2018-15805 A cross-site request forgery vulnerability exists in Jenkins vSphere Plugin 2.16 and… CVSS 3.0HIGH 8.8
  • TI-2018-15804 An improper authorization vulnerability exists in Jenkins vSphere Plugin 2.16 and older… CVSS 3.0MEDIUM 6.3

Sources