Read the docs

A cross-site request forgery vulnerability exists in Jenkins vSphere Plugin 2.16 and…

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery vulnerability exists in Jenkins vSphere Plugin 2.16 and older in Clone.java, CloudSelectorParameter.java, ConvertToTemplate.java, ConvertToVm.java, Delete.java, DeleteSnapshot.java, Deploy.java, ExposeGuestInfo.java, FolderVSphereCloudProperty.java, PowerOff.java, PowerOn.java, Reconfigure.java, Rename.java, RenameSnapshot.java, RevertToSnapshot.java, SuspendVm.java, TakeSnapshot.java, VSphereBuildStepContainer.java, vSphereCloudProvisionedSlave.java, vSphereCloudSlave.java, vSphereCloudSlaveTemplate.java, VSphereConnectionConfig.java, vSphereStep.java that allows attackers to perform form validation related actions, including sending numerous requests to the configured vSphere server, potentially resulting in denial of service, or send credentials stored in Jenkins with known ID to an attacker-specified server ("test connection").

Why it matters now

EPSS 0.00675 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:vsphere-cloud (Maven): 2.17

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins:vsphere-cloud (Maven)before 2.172.17Patch availableGHSA-2g32-2j8w-2qgf
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:vsphere-cloud (Maven) Vendor— Affected before 2.17 Fixed in 2.17 Patch available GHSA-2g32-2j8w-2qgf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:vsphere:*:*:*:*:*:jenkins:*:*up to 2.16VulnerableJenkins
  • cpe:2.3:a:jenkins:vsphere:*:*:*:*:*:jenkins:*:* Versions up to 2.16 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-2g32-2j8w-2qgf org.jenkins-ci.plugins:vsphere-cloud (Maven) Fixed in 2.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000153
  2. 2026-10-03 Alias added: GHSA-2g32-2j8w-2qgf

References

  • TI-2018-15804 An improper authorization vulnerability exists in Jenkins vSphere Plugin 2.16 and older… CVSS 3.0MEDIUM 6.3
  • TI-2018-15803 A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in… CVSS 3.0MEDIUM 5.6

Sources