nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-476.
Summary
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:* | 1.10.0 – 1.31.0 | Vulnerable | nghttp2 |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 6.0.0 – 6.8.1 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 8.4.0 – 8.17.0 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* | 9.0.0 – 9.11.2 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 10.0.0 to before 10.4.1 | Vulnerable | NodeJS |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:* Versions 1.10.0 – 1.31.0 Vulnerable ·nghttp2
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 6.0.0 – 6.8.1 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 8.4.0 – 8.17.0 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions 9.0.0 – 9.11.2 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 10.0.0 to before 10.4.1 Vulnerable ·NodeJS
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
Red Hat 2 advisories
- RHSA-2019:0367 Released 2019-02-18 · Red Hat rating ImportantRed Hat JBoss Core Services Apache HTTP Server 2.4.29 security update
- Red Hat JBoss Core Services on RHEL 6 Server jbcs-httpd24-1-6.jbcs.el6, jbcs-httpd24-apache-commons-daemon-jsvc-1:1.1.0-3.redhat_2.jbcs.el6, jbcs-httpd24-apr-1.6.3-31.jbcs.el6 +31
- Red Hat JBoss Core Services on RHEL 7 Server jbcs-httpd24-1-6.jbcs.el7, jbcs-httpd24-apache-commons-daemon-jsvc-1:1.1.0-3.redhat_2.jbcs.el7, jbcs-httpd24-apr-1.6.3-31.jbcs.el7 +31
- RHSA-2019:0366 Released 2019-02-18 · Red Hat rating ImportantRed Hat JBoss Core Services Apache HTTP Server 2.4.29 SP1 security update
- Red Hat JBoss Core Services
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Core Services | Fixed | RHSA-2019:0366 |
| Red Hat JBoss Core Services on RHEL 6 Server | Fixed | RHSA-2019:0367 |
| Red Hat JBoss Core Services on RHEL 7 Server | Fixed | RHSA-2019:0367 |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000168
- 2026-10-03 Alias added: GHSA-q6fc-wp2r-hvq3
References
Sources
- CVE-2018-1000168 · CVE Program
- CVE-2018-1000168 · NVD
- FIRST EPSS
- GHSA-q6fc-wp2r-hvq3 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000168 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences