Priority CRITICAL 99KEV
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, dis…
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.82641 · Published 2026-10-22 · Partial fix · 1.0.10, 1.1.1 +2 CWE-252
Priority CRITICAL 90KEV
The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.99999 · Published 2023-10-10 · Partial fix · 1.28.0, 0.17.0 +9 CWE-400
Priority HIGH 84
An attacker can make the Node.js HTTP/2 server completely unavailable by sending a small amount of HTTP/2 frames packets with a few HTTP/2 frames inside.
CVSS 3.0HIGH 8.2· Network · No auth · No interaction · EPSS 0.87211 · Published 2024-04-09 · Partial fix · 18.20.1, 20.12.1 +1 CWE-362
Priority HIGH 83
The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other protocols and products, have a birthday bound of approximately four billion blocks, which makes it easier for remote attackers to obt…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.94697 · Published 2016-09-01 · Partial fix CWE-200
Priority HIGH 82
A command inject vulnerability allows an attacker to perform command injection on Windows applications that indirectly depend on the CreateProcess function when the specific conditions are satisfied.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06827 · Published 2024-04-10 · No fix listed CWE-77
Priority HIGH 82
A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.92488 · Published 2022-11-01 · Partial fix · 3.0.7, 300.0.11 CWE-120
Priority HIGH 82
A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9077 · Published 2022-11-01 · Fixed in 300.0.11 CWE-787
Priority HIGH 81
Undici allows duplicate HTTP Content-Length headers when they are provided in an array with case-variant names (e.g., Content-Length and content-length).
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0056 · Published 2026-03-12 · Partial fix · 6.24.0: 7.24.0, 6.24.0 +1 CWE-444
Priority HIGH 81
undici is an HTTP/1.1 client, written from scratch for Node.js.`undici` is vulnerable to SSRF (Server-side Request Forgery) when an application takes in **user input** into the `path/pathname` option of `undici.request`.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01927 · Published 2022-08-12 · Partial fix · 5.8.2 CWE-918
Priority HIGH 77
The BN_mod_sqrt() function, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.73188 · Published 2022-03-15 · Partial fix · 300.0.5, 111.18.0 CWE-835
Priority HIGH 76
OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly restrict processing of ChangeCipherSpec messages, which allows man-in-the-middle attackers to trigger use of a zero-length master key…
CVSS 3.1HIGH 7.4· Network · No auth · No interaction · EPSS 0.95326 · Published 2014-06-05 · Partial fix CWE-326
Priority HIGH 75
HTTP request smuggling in Node.js 10, 12, and 13 causes malicious payload delivery when transfer-encoding is malformed
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.57132 · Published 2020-02-07 · Fixed in 10.19.0, 12.15.0 +1 CWE-444
Priority HIGH 75
Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.87286 · Published 2019-08-13 · Partial fix CWE-400
Priority HIGH 74
Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.82813 · Published 2019-08-13 · Partial fix · 0.0.0-20190813141303-74dc4d7220e7 CWE-400
Priority HIGH 74
Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.83433 · Published 2019-08-13 · Partial fix · 0.0.0-20190813141303-74dc4d7220e7 CWE-400
Priority HIGH 73
Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.81556 · Published 2019-08-13 · Partial fix CWE-400
Priority HIGH 72
A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02209 · Published 2023-02-23 · Partial fix · 14.21.3, 16.19.1 +2 CWE-310
Priority HIGH 72
Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.77385 · Published 2021-03-03 · Partial fix · 10.24.0, 12.21.0 +2 CWE-400
Priority HIGH 70
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.50732 · Published 2021-02-16 · Partial fix · 111.14.0 CWE-190
Priority HIGH 69
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.81832 · Published 2022-07-14 · Fixed in 14.20.0, 16.20.0 +2 CWE-444
Priority HIGH 69
During key agreement in a TLS handshake using a DH(E) based ciphersuite a malicious server can send a very large prime value to the client.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.4701 · Published 2018-06-12 · Partial fix CWE-320
Priority HIGH 69
The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.89058 · Published 2016-05-05 · Partial fix CWE-200
Priority HIGH 68
Undici is an HTTP/1.1 client for Node.js.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.01129 · Published 2023-02-16 · Partial fix · 5.19.1 CWE-93
Priority HIGH 68
The llhttp parser in the http module in Node v18.7.0 does not correctly handle header fields that are not terminated with CLRF.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.02764 · Published 2022-12-05 · Fixed in 14.20.1, 16.17.1 +1 CWE-444
Priority HIGH 68
undici is an HTTP/1.1 client, written from scratch for Node.js.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.01515 · Published 2022-07-19 · Partial fix · 5.8.0 CWE-93
Load more