Read the docs

An exposure of sensitive information vulnerability exists in Jenkins 2.115 and older, LTS…

Priority LOW 27CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

An exposure of sensitive information vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in CLICommand.java and ViewOptionHandler.java that allows unauthorized attackers to confirm the existence of agents or views with an attacker-specified name by sending a CLI command to Jenkins.

Why it matters now

EPSS 0.01376 72nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.107.2, 2.116

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.107.22.107.2Patch availableGHSA-cpw3-x7gf-p872
—org.jenkins-ci.main:jenkins-core (Maven)2.108 to before 2.1162.116Patch availableGHSA-cpw3-x7gf-p872
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.107.2 Fixed in 2.107.2 Patch available GHSA-cpw3-x7gf-p872
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.108 to before 2.116 Fixed in 2.116 Patch available GHSA-cpw3-x7gf-p872

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.105VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.107.1VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.105 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.107.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-cpw3-x7gf-p872 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.107.2 Advisory →
  • Fix · GHSA-cpw3-x7gf-p872 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.116 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10Fixed—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000169
  2. 2026-10-03 Alias added: GHSA-cpw3-x7gf-p872

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources