A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 6 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/model/Api.java that allows attackers to specify URLs to Jenkins that result in rendering arbitrary attacker-controlled HTML by Jenkins.
Why it matters now
EPSS 0.01534 74th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.138.2, 2.146Red Hat: 1 fixed, 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.138.2 | 2.138.2 | Patch available | GHSA-hv45-5j9h-7fhg |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.140 to before 2.146 | 2.146 | Patch available | GHSA-hv45-5j9h-7fhg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.138.2 Fixed in 2.138.2 Patch available GHSA-hv45-5j9h-7fhg
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.140 to before 2.146 Fixed in 2.146 Patch available GHSA-hv45-5j9h-7fhg
Remediation
- Fix · GHSA-hv45-5j9h-7fhg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.138.2 Advisory →
- Fix · GHSA-hv45-5j9h-7fhg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.146 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000407
- 2026-10-03 Alias added: GHSA-hv45-5j9h-7fhg
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-1000407 · CVE Program
- CVE-2018-1000407 · NVD
- FIRST EPSS
- GHSA-hv45-5j9h-7fhg · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000407 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences