Read the docs

A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.1…

Priority HIGH 81CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.1 and earlier in GitHubTokenCredentialsCreator.java that allows attackers to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Why it matters now

EPSS 0.90894 99th percentileScored 2026-11-07
Fix Partial com.coravy.hudson.plugins.github:github (Maven): 1.29.2Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—com.coravy.hudson.plugins.github:github (Maven)before 1.29.21.29.2Patch availableGHSA-6cvm-v6qj-hjq9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • com.coravy.hudson.plugins.github:github (Maven) Vendor— Affected before 1.29.2 Fixed in 1.29.2 Patch available GHSA-6cvm-v6qj-hjq9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:github:*:*:*:*:*:jenkins:*:*up to 1.29.1VulnerableJenkins
  • cpe:2.3:a:jenkins:github:*:*:*:*:*:jenkins:*:* Versions up to 1.29.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-6cvm-v6qj-hjq9 com.coravy.hudson.plugins.github:github (Maven) Fixed in 1.29.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000600
  2. 2026-10-03 Alias added: GHSA-6cvm-v6qj-hjq9

References

  • TI-2026-30806 Cross-site scripting in Jenkins GitHub Plugin CVSS 3.1CRITICAL 9.0
  • TI-2018-15832 A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.0… CVSS 3.0MEDIUM 6.5
  • TI-2023-25152 Cross-site scripting in Jenkins GitHub Plugin CVSS 3.1MEDIUM 5.4
  • TI-2022-17100 Observable discrepancy in Jenkins GitHub Plugin CVSS 3.1MEDIUM 5.3
  • TI-2018-15833 A server-side request forgery vulnerability exists in Jenkins GitHub Plugin 1.29.0 and… CVSS 3.0MEDIUM 5.4

Sources