Cross-site scripting in Jenkins GitHub Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins GitHub Plugin 1.37.3 and earlier does not escape the GitHub project URL on the build page when showing changes, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00721 54th percentileScored 2026-11-07
Fix Fixed com.coravy.hudson.plugins.github:github (Maven): 1.37.3.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins GitHub Plugin | up to 1.37.3 | — | No fix listed | CNA |
| — | com.coravy.hudson.plugins.github:github (Maven) | before 1.37.3.1 | 1.37.3.1 | Patch available | GHSA-mv77-fj63-q5w8 |
- Jenkins GitHub Plugin VendorJenkins Affected up to 1.37.3 Fixed in — No fix listed CNA
- com.coravy.hudson.plugins.github:github (Maven) Vendor— Affected before 1.37.3.1 Fixed in 1.37.3.1 Patch available GHSA-mv77-fj63-q5w8
Remediation
- Fix · GHSA-mv77-fj63-q5w8 com.coravy.hudson.plugins.github:github (Maven) Fixed in 1.37.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46650
- 2026-10-03 Alias added: GHSA-mv77-fj63-q5w8
- 2026-10-26 EPSS moved to the 50th–90th percentile
References
More Jenkins Github vulnerabilities
- TI-2018-15955 A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.1… CVSS 3.0HIGH 8.8
- TI-2026-30806 Cross-site scripting in Jenkins GitHub Plugin CVSS 3.1CRITICAL 9.0
- TI-2018-15832 A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.0… CVSS 3.0MEDIUM 6.5
- TI-2022-17100 Observable discrepancy in Jenkins GitHub Plugin CVSS 3.1MEDIUM 5.3
- TI-2018-15833 A server-side request forgery vulnerability exists in Jenkins GitHub Plugin 1.29.0 and… CVSS 3.0MEDIUM 5.4
Sources
- CVE-2023-46650 · CVE Program
- CVE-2023-46650 · NVD
- FIRST EPSS
- GHSA-mv77-fj63-q5w8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences