A persisted cross-site scripting vulnerability exists in Jenkins Badge Plugin 1.4 and…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A persisted cross-site scripting vulnerability exists in Jenkins Badge Plugin 1.4 and earlier in BadgeSummaryAction.java, HtmlBadgeAction.java that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.
Why it matters now
EPSS 0.00704 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:badge (Maven): 1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:badge (Maven) | before 1.5 | 1.5 | Patch available | GHSA-3xjq-8j89-xrw9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:badge (Maven) Vendor— Affected before 1.5 Fixed in 1.5 Patch available GHSA-3xjq-8j89-xrw9
Remediation
- Fix · GHSA-3xjq-8j89-xrw9 org.jenkins-ci.plugins:badge (Maven) Fixed in 1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000604
- 2026-10-03 Alias added: GHSA-3xjq-8j89-xrw9
References
More Jenkins Badge vulnerabilities
- TI-2022-07277 Cross-site scripting in Jenkins Badge Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2018-1000604 · CVE Program
- CVE-2018-1000604 · NVD
- FIRST EPSS
- GHSA-3xjq-8j89-xrw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences