Cross-site scripting in Jenkins Badge Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Badge Plugin 1.9 and earlier does not escape the description and does not check for allowed protocols when creating a badge, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00867 58th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:badge (Maven): 1.9.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Badge Plugin | up to 1.9 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:badge (Maven) | before 1.9.1 | 1.9.1 | Patch available | GHSA-5qx5-vg5w-5mx3 |
- Jenkins Badge Plugin VendorJenkins Affected up to 1.9 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:badge (Maven) Vendor— Affected before 1.9.1 Fixed in 1.9.1 Patch available GHSA-5qx5-vg5w-5mx3
Remediation
- Fix · GHSA-5qx5-vg5w-5mx3 org.jenkins-ci.plugins:badge (Maven) Fixed in 1.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23108
- 2026-10-03 Alias added: GHSA-5qx5-vg5w-5mx3
References
More Jenkins Badge vulnerabilities
- TI-2018-15959 A persisted cross-site scripting vulnerability exists in Jenkins Badge Plugin 1.4 and… CVSS 3.0MEDIUM 5.4
Sources
- CVE-2022-23108 · CVE Program
- CVE-2022-23108 · NVD
- FIRST EPSS
- GHSA-5qx5-vg5w-5mx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences