A man in the middle vulnerability exists in Jenkins CollabNet Plugin 2.0.4 and earlier in…
Priority LOW 34CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
A man in the middle vulnerability exists in Jenkins CollabNet Plugin 2.0.4 and earlier in CollabNetApp.java, CollabNetPlugin.java, CNFormFieldValidator.java that allows attackers to impersonate any service that Jenkins connects to.
Why it matters now
EPSS 0.00856 58th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:collabnet (Maven): 2.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:collabnet (Maven) | before 2.0.5 | 2.0.5 | Patch available | GHSA-m8x2-4gc8-9v3r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:collabnet (Maven) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-m8x2-4gc8-9v3r
Remediation
- Fix · GHSA-m8x2-4gc8-9v3r org.jenkins-ci.plugins:collabnet (Maven) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000605
- 2026-10-03 Alias added: GHSA-m8x2-4gc8-9v3r
References
More Jenkins Collabnet vulnerabilities
- TI-2022-18198 Insufficiently protected credentials in Jenkins CollabNet Plugins Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2018-1000605 · CVE Program
- CVE-2018-1000605 · NVD
- FIRST EPSS
- GHSA-m8x2-4gc8-9v3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences