Read the docs
TI-2022-18198 Aliases CVE-2022-38665GHSA-qh87-2qvh-5jf8

Insufficiently protected credentials in Jenkins CollabNet Plugins Plugin

Priority LOW 30CWE-522Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

Jenkins CollabNet Plugins Plugin 2.0.8 and earlier stores a RabbitMQ password unencrypted in its global configuration file on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.

Why it matters now

EPSS 0.0083 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:collabnet (Maven): 2.0.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins CollabNet Plugins Pluginup to 2.0.8—No fix listedCNA
—org.jenkins-ci.plugins:collabnet (Maven)before 2.0.92.0.9Patch availableGHSA-qh87-2qvh-5jf8
  • Jenkins CollabNet Plugins Plugin VendorJenkins Affected up to 2.0.8 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:collabnet (Maven) Vendor— Affected before 2.0.9 Fixed in 2.0.9 Patch available GHSA-qh87-2qvh-5jf8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:collabnet:*:*:*:*:*:jenkins:*:*up to 2.0.8VulnerableJenkins
  • cpe:2.3:a:jenkins:collabnet:*:*:*:*:*:jenkins:*:* Versions up to 2.0.8 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-qh87-2qvh-5jf8 org.jenkins-ci.plugins:collabnet (Maven) Fixed in 2.0.9 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-38665
  2. 2026-10-03 Alias added: GHSA-qh87-2qvh-5jf8

References

  • TI-2018-15960 A man in the middle vulnerability exists in Jenkins CollabNet Plugin 2.0.4 and earlier in… CVSS 3.0HIGH 7.4

Sources