Microweber version <= 1.0.7 contains a Cross Site Scripting (XSS) vulnerability in Admin…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Microweber version <= 1.0.7 contains a Cross Site Scripting (XSS) vulnerability in Admin login form template that can result in Execution of JavaScript code.
Why it matters now
EPSS 0.01323 71st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed microweber/microweber (Packagist): 1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | microweber/microweber (Packagist) | before 1.1 | 1.1 | Patch available | GHSA-xmcr-x5x3-gjfx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- microweber/microweber (Packagist) Vendor— Affected before 1.1 Fixed in 1.1 Patch available GHSA-xmcr-x5x3-gjfx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* | up to 1.0.7 | Vulnerable | microweber |
- cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* Versions up to 1.0.7 Vulnerable ·microweber
Remediation
- Fix · GHSA-xmcr-x5x3-gjfx microweber/microweber (Packagist) Fixed in 1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000826
- 2026-10-03 Alias added: GHSA-xmcr-x5x3-gjfx
References
Exploit 2
More Microweber vulnerabilities
- TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
- TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
- TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
- TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
- TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
- TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
Sources
- CVE-2018-1000826 · CVE Program
- CVE-2018-1000826 · NVD
- FIRST EPSS
- GHSA-xmcr-x5x3-gjfx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences