Path traversal in NodeJS adm-zip
Priority MEDIUM 40CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Why it matters now
EPSS 0.13454 96th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial adm-zip (node.js): 0.4.9adm-zip (npm): 0.4.11Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | adm-zip | before 0.4.9 | 0.4.9 | Patch available | CNA |
| — | adm-zip (npm) | before 0.4.11 | 0.4.11 | Patch available | GHSA-3v6h-hqm4-2rg6 |
- adm-zip VendorNodeJS Affected before 0.4.9 Fixed in 0.4.9 Patch available CNA
- adm-zip (npm) Vendor— Affected before 0.4.11 Fixed in 0.4.11 Patch available GHSA-3v6h-hqm4-2rg6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adm-zip_project:adm-zip:*:*:*:*:*:node.js:*:* | before 0.4.9 | Vulnerable | Adm-zip Project |
- cpe:2.3:a:adm-zip_project:adm-zip:*:*:*:*:*:node.js:*:* Versions before 0.4.9 Vulnerable ·Adm-zip Project
Remediation
- Fix · CNA adm-zip (node.js) Fixed in 0.4.9
- Fix · GHSA-3v6h-hqm4-2rg6 adm-zip (npm) Fixed in 0.4.11 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Mobile Application Platform 4 | Affected | No fix yet |
| Red Hat Quay 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1002204
- 2026-10-03 Alias added: GHSA-3v6h-hqm4-2rg6
References
Exploit 2
Advisory 2
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2018-1002204 · CVE Program
- CVE-2018-1002204 · NVD
- FIRST EPSS
- GHSA-3v6h-hqm4-2rg6 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1002204 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences