Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF)…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1999017
- 2026-10-03 Alias added: GHSA-528p-fqc4-66rm
References
More Pydio vulnerabilities
- TI-2024-26880 Pydio Core <= 8.2.5 is vulnerable to Cross Site Scripting (XSS) via the New URL Bookmark feature. CVSS 3.1MEDIUM 5.4
- TI-2015-03029 Pydio (formerly AjaXplorer) before 6.0.7 allows remote attackers to execute arbitrary… CVSS 3.0CRITICAL 9.8
- TI-2013-03735 OS command injection in Ajaxeplorer CVSS 3.1CRITICAL 9.8
- TI-2018-14701 In Pydio before 8.2.2, an attack is possible via PHP Object Injection because a user is… CVSS 3.0CRITICAL 9.8
- TI-2019-07057 An issue was discovered in proxy.php in pydio-core in Pydio through 8.2.2. CVSS 3.0CRITICAL 9.8
- TI-2013-05239 Unrestricted file upload vulnerability in plugins/editor.zoho/agent/save_zoho.php in the… CVSS 2.0HIGH 7.5
Sources
- CVE-2018-1999017 · CVE Program
- CVE-2018-1999017 · NVD
- FIRST EPSS
- GHSA-528p-fqc4-66rm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences