Read the docs

A improper authentication vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and…

Priority LOW 26CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 9 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.

Summary

A improper authentication vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in SecurityRealm.java, TokenBasedRememberMeServices2.java that allows attackers with a valid cookie to remain logged in even if that feature is disabled.

Why it matters now

EPSS 0.00874 59th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.121.3, 2.138Red Hat: 9 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.121.32.121.3Patch availableGHSA-q4cq-r7hg-pxqq
—org.jenkins-ci.main:jenkins-core (Maven)2.122 to before 2.1382.138Patch availableGHSA-q4cq-r7hg-pxqq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.121.3 Fixed in 2.121.3 Patch available GHSA-q4cq-r7hg-pxqq
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.122 to before 2.138 Fixed in 2.138 Patch available GHSA-q4cq-r7hg-pxqq

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.121.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.137VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.121.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.137 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-q4cq-r7hg-pxqq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.121.3 Advisory →
  • Fix · GHSA-q4cq-r7hg-pxqq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.138 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.2AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.3AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.4AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.5AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.6AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.7AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 3.9AffectedNo fix yet: Fix deferred
Red Hat OpenShift Enterprise 3.1AffectedNo fix yet: Fix deferred
Not affected: 1 product
  • Red Hat OpenShift Container Platform 3.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1999045
  2. 2026-10-03 Alias added: GHSA-q4cq-r7hg-pxqq

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources