Read the docs
TI-2019-00279 Aliases CVE-2019-0337GHSA-c356-2qc6-xmc3

Cross-site scripting in SAP NetWeaver Process Integration

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Java Proxy Runtime of SAP NetWeaver Process Integration, versions 7.10, 7.11, 7.30, 7.31, 7.40, 7.50, does not sufficiently encode user-controlled inputs and allows an attacker to execute malicious scripts in the url thereby resulting in Reflected Cross-Site Scripting (XSS) vulnerability

Why it matters now

EPSS 0.00843 58th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Process Integration (Java Proxy Runtime) (SAP SE): 7.10, 7.11, 7.30 +3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SAPSAP NetWeaver Process Integration (Java Proxy Runtime)before 7.10; before 7.11; before 7.30; before 7.31; before 7.40; before 7.507.10, 7.11, 7.30, 7.31, 7.40, 7.50Patch availableCNA
  • SAP NetWeaver Process Integration (Java Proxy Runtime) VendorSAP Affected before 7.10; before 7.11; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.11, 7.30, 7.31, 7.40, 7.50 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:sap:netweaver_process_integration:7.10:*:*:*:*:*:*:*7.10VulnerableSAP
cpe:2.3:a:sap:netweaver_process_integration:7.11:*:*:*:*:*:*:*7.11VulnerableSAP
cpe:2.3:a:sap:netweaver_process_integration:7.30:*:*:*:*:*:*:*7.30VulnerableSAP
cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:*7.31VulnerableSAP
cpe:2.3:a:sap:netweaver_process_integration:7.40:*:*:*:*:*:*:*7.40VulnerableSAP
cpe:2.3:a:sap:netweaver_process_integration:7.50:*:*:*:*:*:*:*7.50VulnerableSAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
  • cpe:2.3:a:sap:netweaver_process_integration:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP

Remediation

  • Fix · CNA SAP NetWeaver Process Integration (Java Proxy Runtime) (SAP SE) Fixed in 7.10, 7.11, 7.30, 7.31, 7.40, 7.50

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-0337
  2. 2026-10-03 Alias added: GHSA-c356-2qc6-xmc3

References

  • TI-2022-19777 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.9
  • TI-2022-19776 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.4
  • TI-2019-00271 OS command injection in SAP NetWeaver Process Integration ABAP tests CVSS 3.0HIGH 7.2
  • TI-2023-17944 Missing Authentication check in SAP NetWeaver Process Integration (Runtime Workbench) CVSS 3.1MEDIUM 6.5
  • TI-2023-17943 Missing Authentication check in SAP NetWeaver Process Integration (Message Display Tool) CVSS 3.1MEDIUM 6.5
  • TI-2019-00262 Under certain conditions the PI Integration Builder Web UI of SAP NetWeaver Process… CVSS 3.0HIGH 7.5
See all 20 →

Sources