Improper input validation in Cisco Adaptive Security Appliance Software
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability in the TCP proxy functionality for Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to restart unexpectedly, resulting in a denial of service (DoS) condition. The vulnerability is due to an error in TCP-based packet inspection, which could cause the TCP packet to have an invalid Layer 2 (L2)-formatted header. An attacker could exploit this vulnerability by sending a crafted TCP packet sequence to the targeted device. A successful exploit could allow the attacker to cause a DoS condition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Adaptive Security Appliance (ASA) Software | before 9.4.4.34; before 9.8.4; before 9.9.2.50 | 9.4.4.34, 9.8.4, 9.9.2.50 | Patch available | CNA |
- Cisco Adaptive Security Appliance (ASA) Software VendorCisco Affected before 9.4.4.34; before 9.8.4; before 9.9.2.50 Fixed in 9.4.4.34, 9.8.4, 9.9.2.50 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | before 9.4.4.34 | Vulnerable | Cisco |
| cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions before 9.4.4.34 Vulnerable ·Cisco
- cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* | 6.0.0 to before 6.2.3.12; 6.3.0 to before 6.3.0.3 | Vulnerable | Cisco |
- cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* Versions 6.0.0 to before 6.2.3.12; 6.3.0 to before 6.3.0.3 Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Adaptive Security Appliance (ASA) Software (Cisco) Fixed in 9.4.4.34, 9.8.4, 9.9.2.50
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1687
- 2026-10-03 Alias added: GHSA-f5pm-8fcr-v6cq
References
More Cisco Adaptive Security Appliance Software vulnerabilities
- TI-2025-14628 Buffer overflow in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.9
- TI-2016-05454 Buffer overflow in Cisco Adaptive Security Appliance (ASA) Software through 9.4.2.3 on… KEVCVSS 3.1HIGH 8.8
- TI-2023-06973 Authentication bypass in Cisco Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.1
- TI-2026-82192 Denial of service in Cisco Secure Firewall ASA and FTD SSL VPN KEVCVSS 3.1HIGH 8.6
- TI-2026-16533 Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense… KEVCVSS 3.1HIGH 8.6
- TI-2025-14657 Missing authorization in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1HIGH 8.6
Sources
- CVE-2019-1687 · CVE Program
- CVE-2019-1687 · NVD
- FIRST EPSS
- GHSA-f5pm-8fcr-v6cq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences