Cisco Web Security Appliance Privilege Escalation Vulnerability
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability in the log subscription subsystem of the Cisco Web Security Appliance (WSA) could allow an authenticated, local attacker to perform command injection and elevate privileges to root. The vulnerability is due to insufficient validation of user-supplied input on the web and command-line interface. An attacker could exploit this vulnerability by authenticating to the affected device and injecting scripting commands in the scope of the log subscription subsystem. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system and elevate privileges to root.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Web Security Appliance (WSA) | before 10.1.4-017; before 10.5.4-018; before 11.5.2-020; before 11.7.0-406 | 10.1.4-017, 10.5.4-018, 11.5.2-020, 11.7.0-406 | Patch available | CNA |
- Cisco Web Security Appliance (WSA) VendorCisco Affected before 10.1.4-017; before 10.5.4-018; before 11.5.2-020; before 11.7.0-406 Fixed in 10.1.4-017, 10.5.4-018, 11.5.2-020, 11.7.0-406 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:web_security_appliance:10.5.2-072:*:*:*:*:*:*:* | 10.5.2-072 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.0.0-641:*:*:*:*:*:*:* | 11.0.0-641 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.5.0-fcs-614:*:*:*:*:*:*:* | 11.5.0-fcs-614 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:wsa10.5.0-fcs-000:*:*:*:*:*:*:* | wsa10.5.0-fcs-000 | Vulnerable | Cisco |
- cpe:2.3:a:cisco:web_security_appliance:10.5.2-072:*:*:*:*:*:*:* Versions 10.5.2-072 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.0.0-641:*:*:*:*:*:*:* Versions 11.0.0-641 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.5.0-fcs-614:*:*:*:*:*:*:* Versions 11.5.0-fcs-614 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:wsa10.5.0-fcs-000:*:*:*:*:*:*:* Versions wsa10.5.0-fcs-000 Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Web Security Appliance (WSA) (Cisco) Fixed in 10.1.4-017, 10.5.4-018, 11.5.2-020, 11.7.0-406
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1816
- 2026-10-03 Alias added: GHSA-846c-pcw3-c872
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
More Cisco Web Security Appliance vulnerabilities
- TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
- TI-2018-00369 Uncontrolled resource consumption in Cisco AsyncOS Software for Cisco Web Security… CVSS 3.0HIGH 8.6
- TI-2019-01508 Cisco Web Security Appliance HTTPS Certificate Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2018-00312 A vulnerability in traffic-monitoring functions in Cisco Web Security Appliance (WSA)… CVSS 3.0HIGH 7.5
- TI-2021-01086 Cisco Web Security Appliance Privilege Escalation Vulnerability CVSS 3.1HIGH 8.8
- TI-2019-11999 Cisco Web Security Appliance Unauthorized Device Reset Vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2019-1816 · CVE Program
- CVE-2019-1816 · NVD
- FIRST EPSS
- GHSA-846c-pcw3-c872 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences