Cisco Integrated Management Controller Unauthenticated Denial of Service Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
A vulnerability in the web server of Cisco Integrated Management Controller (IMC) could allow an unauthenticated, remote attacker to cause the web server process to crash, causing a denial of service (DoS) condition on an affected system. The vulnerability is due to insufficient validation of user-supplied input on the web interface. An attacker could exploit this vulnerability by submitting a crafted HTTP request to certain endpoints of the affected software. A successful exploit could allow an attacker to cause the web server to crash. Physical access to the device may be required for a restart.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Unified Computing System (Management Software) | before 4.0(2f) | 4.0(2f) | Patch available | CNA |
- Cisco Unified Computing System (Management Software) VendorCisco Affected before 4.0(2f) Fixed in 4.0(2f) Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:unified_computing_system:4.0\(1c\)hs3:*:*:*:*:*:*:* | 4.0(1c)hs3 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* | 4.0.0.0 to before 4.0\(2f\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:ucs_c125_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs_c4200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs_s3260:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:a:cisco:unified_computing_system:4.0\(1c\)hs3:*:*:*:*:*:*:* Versions 4.0(1c)hs3 Vulnerable ·Cisco
- cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* Versions 4.0.0.0 to before 4.0\(2f\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:ucs_c125_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs_c4200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs_s3260:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco Unified Computing System (Management Software) (Cisco) Fixed in 4.0(2f)
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Unified Computing System (Management Software) 4.0(2f)
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2019-01528 Cisco Integrated Management Controller Substring Comparison Privilege Escalation VulnerabilityPriority MEDIUM 43
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1900
- 2026-10-03 Alias added: GHSA-7674-7g97-mwgj
References
More Cisco Integrated Management Controller Supervisor vulnerabilities
- TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
- TI-2019-01555 Hard-coded credentials in Cisco Unified Computing System Director CVSS 3.1CRITICAL 9.8
- TI-2019-01557 Improper authentication in Cisco Unified Computing System Director CVSS 3.0CRITICAL 9.8
- TI-2019-01556 Improper input validation in Cisco Unified Computing System Director CVSS 3.1HIGH 7.2
- TI-2019-01594 Improper authentication in Cisco Unified Computing System Director CVSS 3.0CRITICAL 9.8
- TI-2019-01487 Cisco Integrated Management Controller Command Injection Vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2019-1900 · CVE Program
- CVE-2019-1900 · NVD
- FIRST EPSS
- GHSA-7674-7g97-mwgj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences