$mod can result in undefined behavior
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which use the $mod operator to overflow negative values. This issue affects: MongoDB Inc. MongoDB Server v4.4 versions prior to 4.4.1; v4.2 versions prior to 4.2.9; v4.0 versions prior to 4.0.20; v3.6 versions prior to 3.6.20.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 3.6 to before 3.6.20; 4.0 to before 4.0.20; 4.2 to before 4.2.9; 4.4 to before 4.4.1 | 3.6.20, 4.0.20, 4.2.9, 4.4.1 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 3.6 to before 3.6.20; 4.0 to before 4.0.20; 4.2 to before 4.2.9; 4.4 to before 4.4.1 Fixed in 3.6.20, 4.0.20, 4.2.9, 4.4.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* | 3.6.0 to before 3.6.20; 4.0.0 to before 4.0.20; 4.2.0 to before 4.2.9; 4.4.0 to before 4.4.1 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 3.6.0 to before 3.6.20; 4.0.0 to before 4.0.20; 4.2.0 to before 4.2.9; 4.4.0 to before 4.4.1 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB Inc.) Fixed in 3.6.20, 4.0.20, 4.2.9, 4.4.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MongoDB Server 3.6.20, 4.0.20 and 2 more versions
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2020-06411 Improper neutralization of null byte leads to read overrunPriority LOW 32
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Update Infrastructure 3 for Cloud Providers | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Advanced Cluster Management for Kubernetes 2
Timeline
- 2026-10-02 Threatist record created from CVE-2019-2392
- 2026-10-03 Alias added: GHSA-6wx3-3pp4-7q95
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2019-2392 · CVE Program
- CVE-2019-2392 · NVD
- FIRST EPSS
- GHSA-6wx3-3pp4-7q95 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-2392 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences