Uncontrolled search path in Dell Command Update
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-427.
Summary
Dell Command Update versions prior to 3.1 contain an Arbitrary File Deletion Vulnerability. A local authenticated malicious user with low privileges potentially could exploit this vulnerability to delete arbitrary files by creating a symlink from the "Temp\IC\ICDebugLog.txt" to any targeted file. This issue occurs because of insecure handling of Temp directory permissions that were set incorrectly.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Dell Command Update (DCU) (Dell) Fixed in 3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Command Update (DCU) 3.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-02766 Uncontrolled search path in Dell Command UpdatePriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3750
- 2026-10-03 Alias added: GHSA-p5h2-gjvx-mxw2
References
More Dell Command Update vulnerabilities
- TI-2026-42154 Missing authorization in Dell Command Update CVSS 3.1HIGH 8.8
- TI-2024-19153 Dell Command | Update, Dell Update, and Alienware Update UWP, versions prior to 5.4… CVSS 3.1HIGH 7.5
- TI-2026-36723 Deserialization of untrusted data in Dell Command Update CVSS 3.1HIGH 7.8
- TI-2026-36722 Deserialization of untrusted data in Dell Command Update CVSS 3.1HIGH 7.8
- TI-2022-15283 Improper privilege management in Dell SupportAssist Client Consumer CVSS 3.1HIGH 7.8
- TI-2026-42153 Incorrect default permissions in Dell Command Update CVSS 3.1HIGH 7.8
Sources
- CVE-2019-3750 · CVE Program
- CVE-2019-3750 · NVD
- FIRST EPSS
- GHSA-p5h2-gjvx-mxw2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences