Time-of-check time-of-use race condition in Plataformatec Devise ruby gem
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-307.
Summary
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Plataformatec | Devise ruby gem | 4.5.0 and earlier using the lockable module | — | No fix listed | CNA |
| — | devise (RubyGems) | before 4.6.0 | 4.6.0 | Patch available | GHSA-73rf-6mrf-759q |
- Devise ruby gem VendorPlataformatec Affected 4.5.0 and earlier using the lockable module Fixed in — No fix listed CNA
- devise (RubyGems) Vendor— Affected before 4.6.0 Fixed in 4.6.0 Patch available GHSA-73rf-6mrf-759q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plataformatec:devise:*:*:*:*:*:*:*:* | up to 4.5.0 | Vulnerable | Plataformatec |
- cpe:2.3:a:plataformatec:devise:*:*:*:*:*:*:*:* Versions up to 4.5.0 Vulnerable ·Plataformatec
Remediation
- Fix · GHSA-73rf-6mrf-759q devise (RubyGems) Fixed in 4.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5421
- 2026-10-03 Alias added: GHSA-73rf-6mrf-759q
References
More Plataformatec Devise vulnerabilities
- TI-2013-00167 Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before… CVSS 2.0MEDIUM 6.8
- TI-2019-12102 An issue was discovered in Plataformatec Devise before 4.7.1. CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-5421 · CVE Program
- CVE-2019-5421 · NVD
- FIRST EPSS
- GHSA-73rf-6mrf-759q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences