An issue was discovered in Plataformatec Devise before 4.7.1.
Priority LOW 28CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
An issue was discovered in Plataformatec Devise before 4.7.1. It confirms accounts upon receiving a request with a blank confirmation_token, if a database record has a blank value in the confirmation_token column. (However, there is no scenario within Devise itself in which such database records would exist.)
Why it matters now
EPSS 0.01832 79th percentileScored 2026-11-07
Fix Fixed devise (RubyGems): 4.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | devise (RubyGems) | before 4.7.1 | 4.7.1 | Patch available | GHSA-fcjw-8rhj-gwwc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- devise (RubyGems) Vendor— Affected before 4.7.1 Fixed in 4.7.1 Patch available GHSA-fcjw-8rhj-gwwc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plataformatec:devise:*:*:*:*:*:*:*:* | before 4.7.1 | Vulnerable | Plataformatec |
- cpe:2.3:a:plataformatec:devise:*:*:*:*:*:*:*:* Versions before 4.7.1 Vulnerable ·Plataformatec
Remediation
- Fix · GHSA-fcjw-8rhj-gwwc devise (RubyGems) Fixed in 4.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16109
- 2026-10-03 Alias added: GHSA-fcjw-8rhj-gwwc
References
Advisory 3
More Plataformatec Devise vulnerabilities
- TI-2019-03831 Time-of-check time-of-use race condition in Plataformatec Devise ruby gem CVSS 3.1CRITICAL 9.8
- TI-2013-00167 Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2019-16109 · CVE Program
- CVE-2019-16109 · NVD
- FIRST EPSS
- GHSA-fcjw-8rhj-gwwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences