Read the docs
TI-2019-04195 Aliases CVE-2019-5884GHSA-jcgc-vxqg-85xx

php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl…

Priority LOW 29CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl extension is enabled and safe_mode or open_basedir is not set.

Why it matters now

EPSS 0.01275 70th percentileScored 2026-11-07
Fix Fixed studio-42/elfinder (Packagist): 2.1.45

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—studio-42/elfinder (Packagist)before 2.1.452.1.45Patch availableGHSA-jcgc-vxqg-85xx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • studio-42/elfinder (Packagist) Vendor— Affected before 2.1.45 Fixed in 2.1.45 Patch available GHSA-jcgc-vxqg-85xx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:std42:elfinder:*:*:*:*:*:*:*:*before 2.1.45VulnerableStd42
  • cpe:2.3:a:std42:elfinder:*:*:*:*:*:*:*:* Versions before 2.1.45 Vulnerable ·Std42

Remediation

  • Fix · GHSA-jcgc-vxqg-85xx studio-42/elfinder (Packagist) Fixed in 2.1.45 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-5884
  2. 2026-10-03 Alias added: GHSA-jcgc-vxqg-85xx

References

  • TI-2019-06652 elFinder before 2.1.48 has a command injection vulnerability in the PHP connector. CVSS 3.0CRITICAL 9.8
  • TI-2023-28504 Studio-42 eLfinder 2.1.62 is vulnerable to Remote Code Execution (RCE) as there is no… CVSS 3.1CRITICAL 9.8
  • TI-2021-12350 Multiple vulnerabilities leading to RCE CVSS 3.1CRITICAL 9.8
  • TI-2022-10186 connector.minimal.php in std42 elFinder through 2.1.60 is affected by path traversal. CVSS 3.1CRITICAL 9.1
  • TI-2021-19360 A File Upload vulnerability exists in Studio-42 elFinder 2.0.4 to 2.1.59 via… CVSS 3.1CRITICAL 9.8
  • TI-2022-10265 In Studio-42 elFinder 2.1.60, there is a vulnerability that causes remote code execution… CVSS 3.1CRITICAL 9.8
See all 15 →

Sources