An issue was discovered in phpMyAdmin before 4.8.5.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.8 to before 4.8.5 | 4.8.5 | Patch available | GHSA-c8wj-q36q-3wg4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.8 to before 4.8.5 Fixed in 4.8.5 Patch available GHSA-c8wj-q36q-3wg4
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | 4.0.0 – 4.8.4 | Vulnerable | phpMyAdmin |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.0.0 – 4.8.4 Vulnerable ·phpMyAdmin
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-c8wj-q36q-3wg4 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.8.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6799
- 2026-10-03 Alias added: GHSA-c8wj-q36q-3wg4
References
Sources
- CVE-2019-6799 · CVE Program
- CVE-2019-6799 · NVD
- FIRST EPSS
- GHSA-c8wj-q36q-3wg4 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-6799 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences