Read the docs
TI-2019-05058 Aliases CVE-2019-7139GHSA-4j6w-9rf8-hg7r

SQL injection in Magento Open Source

Priority MEDIUM 62CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

Why it matters now

EPSS 0.22242 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Magento Open Source (Magento): 1.9.4.1Magento Commerce (Magento): 1.14.4.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
MagentoMagento Open Sourcebefore 1.9.4.11.9.4.1Patch availableCNA
MagentoMagento Commercebefore 1.14.4.11.14.4.1Patch availableCNA
MagentoMagentobefore 2.1.17; before 2.2.8; before 2.3.12.1.17, 2.2.8, 2.3.1Patch availableCNA
—magento/community-edition (Packagist)2.1.0 to before 2.1.182.1.18Patch availableGHSA-4j6w-9rf8-hg7r
—magento/community-edition (Packagist)2.2.0 to before 2.2.92.2.9Patch availableGHSA-4j6w-9rf8-hg7r
—magento/community-edition (Packagist)2.3.0 to before 2.3.22.3.2Patch availableGHSA-4j6w-9rf8-hg7r
  • Magento Open Source VendorMagento Affected before 1.9.4.1 Fixed in 1.9.4.1 Patch available CNA
  • Magento Commerce VendorMagento Affected before 1.14.4.1 Fixed in 1.14.4.1 Patch available CNA
  • Magento VendorMagento Affected before 2.1.17; before 2.2.8; before 2.3.1 Fixed in 2.1.17, 2.2.8, 2.3.1 Patch available CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.1.0 to before 2.1.18 Fixed in 2.1.18 Patch available GHSA-4j6w-9rf8-hg7r
  • magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.9 Fixed in 2.2.9 Patch available GHSA-4j6w-9rf8-hg7r
  • magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-4j6w-9rf8-hg7r

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*before 1.9.4.1VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*1.14.0.0 to before 1.14.4.1; 2.1.0 to before 2.1.17VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.1.0 to before 2.1.17VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.2.0 to before 2.2.8VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.2.0 to before 2.2.8VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.3.0 to before 2.3.1VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.3.0 to before 2.3.1VulnerableMagento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions before 1.9.4.1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 1.14.0.0 to before 1.14.4.1; 2.1.0 to before 2.1.17 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.1.0 to before 2.1.17 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.2.0 to before 2.2.8 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 to before 2.2.8 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 to before 2.3.1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 to before 2.3.1 Vulnerable ·Magento

Remediation

  • Fix · CNA Magento Open Source (Magento) Fixed in 1.9.4.1
  • Fix · CNA Magento Commerce (Magento) Fixed in 1.14.4.1
  • Fix · CNA Magento (Magento) Fixed in 2.1.17, 2.2.8, 2.3.1
  • Fix · GHSA-4j6w-9rf8-hg7r magento/community-edition (Packagist) Fixed in 2.1.18 Advisory →
  • Fix · GHSA-4j6w-9rf8-hg7r magento/community-edition (Packagist) Fixed in 2.2.9 Advisory →
  • Fix · GHSA-4j6w-9rf8-hg7r magento/community-edition (Packagist) Fixed in 2.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-7139
  2. 2026-10-03 Alias added: GHSA-4j6w-9rf8-hg7r

References

  • TI-2016-03411 Magento CE and EE before 2.0.6 allows remote attackers to conduct PHP objection injection… CVSS 3.0CRITICAL 9.8
  • TI-2021-04135 Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution CVSS 3.1MEDIUM 4.8
  • TI-2015-01273 SQL injection vulnerability in the getCsvFile function in the… CVSS 2.0MEDIUM 6.5
  • TI-2022-15170 Adobe Commerce Stored XSS Arbitrary code execution CVSS 3.1MEDIUM 4.8
  • TI-2020-03231 Deserialization of untrusted data in Adobe Magento CVSS 3.1CRITICAL 9.8
  • TI-2020-07751 Deserialization of untrusted data in Adobe Magento CVSS 3.1CRITICAL 9.8
See all 220 →

Sources