Command Injection Vulnerability in QTS and QuTS hero
Priority MEDIUM 47CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
This command injection vulnerability allows attackers to execute arbitrary commands in a compromised application. QNAP have already fixed this vulnerability in the following versions of QTS and QuTS hero. QuTS hero h4.5.1.1472 build 20201031 and later QTS 4.5.1.1456 build 20201015 and later QTS 4.4.3.1354 build 20200702 and later
Why it matters now
EPSS 0.02718 86th percentileScored 2026-11-07
Fix Fixed QTS (QNAP Systems Inc.): 4.5.1.1456, 4.4.3.1354
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QTS | before 4.5.1.1456; before 4.4.3.1354 | 4.5.1.1456, 4.4.3.1354 | Patch available | CNA |
| QNAP | QuTS hero | < h4.5.1.1472 | — | No fix listed | CNA |
Remediation
- Fix · CNA QTS (QNAP Systems Inc.) Fixed in 4.5.1.1456, 4.4.3.1354
Timeline
- 2026-10-02 Threatist record created from CVE-2019-7198
- 2026-10-03 Alias added: GHSA-rxjr-qfmr-c739
References
More QNAP Qts vulnerabilities
- TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14137 Improper input validation in QNAP QTS KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14131 Cross-site scripting in QNAP QTS KEVCVSS 3.1HIGH 8.0
Sources
- CVE-2019-7198 · CVE Program
- CVE-2019-7198 · NVD
- FIRST EPSS
- GHSA-rxjr-qfmr-c739 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences