Race condition in Elasticsearch
Priority LOW 28CWE-362Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 14 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.
Why it matters now
EPSS 0.01008 63rd percentileScored 2026-11-07
Fix Partial org.elasticsearch:elasticsearch (Maven): 6.8.2, 7.2.1Red Hat: 14 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | before 7.2.1 and 6.8.2 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | before 6.8.2 | 6.8.2 | Patch available | GHSA-jqm6-m3j3-8gg9 |
| — | org.elasticsearch:elasticsearch (Maven) | 7.0.0 to before 7.2.1 | 7.2.1 | Patch available | GHSA-jqm6-m3j3-8gg9 |
- Elasticsearch VendorElastic Affected before 7.2.1 and 6.8.2 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 6.8.2 Fixed in 6.8.2 Patch available GHSA-jqm6-m3j3-8gg9
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.0.0 to before 7.2.1 Fixed in 7.2.1 Patch available GHSA-jqm6-m3j3-8gg9
Remediation
- Fix · GHSA-jqm6-m3j3-8gg9 org.elasticsearch:elasticsearch (Maven) Fixed in 6.8.2 Advisory →
- Fix · GHSA-jqm6-m3j3-8gg9 org.elasticsearch:elasticsearch (Maven) Fixed in 7.2.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Decision Manager 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.2 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.3 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Enterprise 3.1 | Affected | No fix planned: Out of support scope |
| Red Hat Process Automation 7 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Fuse 7
Timeline
- 2026-10-02 Threatist record created from CVE-2019-7614
- 2026-10-03 Alias added: GHSA-jqm6-m3j3-8gg9
References
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-7614 · CVE Program
- CVE-2019-7614 · NVD
- FIRST EPSS
- GHSA-jqm6-m3j3-8gg9 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-7614 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences