Read the docs

Elastic

Records415All Threatist records
Exploited (KEV)3In CISA KEV
CVSS critical22CVSS 9.0–10.0
CVSS high119CVSS 7.0–8.9

Exploited now

Elastic records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

91 records in Elasticsearch · all components

Priority CRITICAL 100KEV

The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to bypass the sandbox protection mechanism and execute arbitrary shell commands via a crafted script.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.99906 Published 2015-02-17 Fixed in 1.3.8, 1.4.3 CWE-284
TI-2023-15037 CVE-2023-31419 · GHSA-qwrx-45xf-jjf7

Elasticsearch StackOverflow vulnerability

Priority HIGH 68

A flaw was discovered in Elasticsearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.61069 Published 2023-10-26 Partial fix · 7.17.12, 8.9.0 +2 CWE-121
TI-2021-05135 CVE-2021-22145 · GHSA-q394-h7f5-7f44

Information disclosure in Elasticsearch

Priority HIGH 68

A memory disclosure vulnerability was identified in Elasticsearch 7.10.0 to 7.13.3 error reporting.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.76249 Published 2021-07-21 Fixed in 7.13.4 CWE-200
Priority MEDIUM 42

The fix for CVE-2020-7009 was found to be incomplete.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01743 Published 2020-06-03 Fixed in 6.8.8, 7.6.2 CWE-266
Priority MEDIUM 42

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01881 Published 2020-03-31 Fixed in 6.8.8, 7.6.2 CWE-266
TI-2018-02801 CVE-2018-3831 · GHSA-r9fv-qpm9-rj4g

Information disclosure in Elasticsearch

Priority MEDIUM 42

Elasticsearch Alerting and Monitoring in versions before 6.4.1 or 5.6.12 have an information disclosure issue when secrets are configured via the API.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01985 Published 2018-09-19 Partial fix · 5.6.12, 6.4.1 CWE-200
Priority MEDIUM 41

The native inference process that Elasticsearch uses to evaluate uploaded machine learning models accepts a model operation that computes a memory address from an offset supplied inside the model, without validating that…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00604 Published 2026-08-13 No fix listed CWE-823
TI-2021-15695 CVE-2021-37937 · GHSA-4qh7-cr89-jx92

Elasticsearch privilege escalation

Priority LOW 39

An issue was found with how API keys are created with the Fleet-Server service account.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00714 Published 2023-11-22 Fixed in 7.14.0 CWE-269
TI-2019-05365 CVE-2019-7611 · GHSA-fj32-6v7m-57pg

Improper access control in Elasticsearch

Priority LOW 39

A permission issue was found in Elasticsearch versions before 5.6.15 and 6.6.1 when Field Level Security and Document Level Security are disabled and the _aliases, _shrink, or _split endpoints are used .

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.02149 Published 2019-03-25 Partial fix · 5.6.15, 6.6.1 CWE-284
Priority LOW 37

An issue has been identified with how Elasticsearch handled incoming requests on the HTTP layer.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0205 Published 2023-10-26 Partial fix · 8.8.2, 3.6.0 +2 CWE-400
Priority LOW 35

Allocation of Resources Without Limits or Throttling (CWE-770) in Elasticsearch can allow a low-privileged authenticated user to cause Excessive Allocation (CAPEC-130) causing a persistent denial of service (OOM crash) v…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00323 Published 2025-12-18 Partial fix · 8.19.9, 9.1.9 +1 CWE-770
Priority LOW 35

A flaw was discovered in Elasticsearch, where processing a document in a deeply nested pipeline on an ingest node could cause the Elasticsearch node to crash.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01254 Published 2024-03-27 Partial fix · 7.17.19, 8.13.0 CWE-400
Priority LOW 34

Incorrect Authorization (CWE-863) in Elasticsearch can lead to Privilege Escalation via a delegated administrative privilege whose scope is not fully enforced during authorization checks.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.0034 Published 2026-10-06 No fix listed CWE-863
TI-2025-25087 CVE-2025-37731 · GHSA-m9gh-789g-q5pv

Elasticsearch Improper Authentication

Priority LOW 34

Improper Authentication in Elasticsearch PKI realm can lead to user impersonation via specially crafted client certificates.

CVSS 3.1HIGH 7.4 Network No auth No interaction EPSS 0.00192 Published 2025-12-15 Partial fix · 8.19.8, 9.1.8 +1 CWE-287
Priority LOW 34

An issue was discovered in Elasticsearch, where a large recursion using the Well-KnownText formatted string with nested GeometryCollection objects could cause a stackoverflow.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00594 Published 2025-04-08 Fixed in 7.17.24, 8.15.1 CWE-400
Priority LOW 34

Uncontrolled Resource Consumption in Elasticsearch while evaluating specifically crafted search templates with Mustache functions can lead to Denial of Service by causing the Elasticsearch node to crash.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00659 Published 2025-05-01 Partial fix · 7.17.25, 8.16.0 CWE-400
TI-2023-25175 CVE-2023-46674 · GHSA-rv74-m283-5j95

Elasticsearch-hadoop Unsafe Deserialization

Priority LOW 34

An issue was identified that allowed the unsafe deserialization of java objects from hadoop or spark configuration properties that could have been modified by authenticated users.

CVSS 3.1HIGH 7.8 Local Low privileges No interaction EPSS 0.00243 Published 2023-12-05 Fixed in 7.17.11, 8.9.0 CWE-502
Priority LOW 34

It was identified that malformed scripts used in the script processor of an Ingest Pipeline could cause an Elasticsearch node to crash when calling the Simulate Pipeline API.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00844 Published 2023-11-22 Partial fix · 7.17.14, 8.10.3 CWE-755
Priority LOW 34

In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.02442 Published 2021-07-26 Partial fix · 6.8.17, 7.13.3 CWE-674
Load more
Open these records in search →