Read the docs
TI-2019-07420 Aliases CVE-2019-10095GHSA-4qw8-pgpr-p9mq

bash command injection in spark interpreter

Priority MEDIUM 51CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.

Summary

bash command injection vulnerability in Apache Zeppelin allows an attacker to inject system commands into Spark interpreter settings. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Why it matters now

EPSS 0.05747 93rd percentileScored 2026-11-07
Fix Fixed org.apache.zeppelin:zeppelin (Maven): 0.10.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache ZeppelinApache Zeppelin – 0.9.0—No fix listedCNA
—org.apache.zeppelin:zeppelin (Maven)before 0.10.00.10.0Patch availableGHSA-4qw8-pgpr-p9mq
  • Apache Zeppelin VendorApache Affected Apache Zeppelin – 0.9.0 Fixed in — No fix listed CNA
  • org.apache.zeppelin:zeppelin (Maven) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-4qw8-pgpr-p9mq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:*up to 0.9.0VulnerableApache
  • cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:* Versions up to 0.9.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-4qw8-pgpr-p9mq org.apache.zeppelin:zeppelin (Maven) Fixed in 0.10.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Apache Zeppelin — GLSA-202311-04

    3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW

    Other records, highest priority first

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10095
  2. 2026-10-03 Alias added: GHSA-4qw8-pgpr-p9mq

References

  • TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injection CVSS 3.1CRITICAL 9.8
  • TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection string CVSS 3.1CRITICAL 9.8
  • TI-2018-01220 Improper authentication in Apache Zeppelin CVSS 3.0HIGH 8.8
  • TI-2017-09344 Session fixation in Apache Zeppelin CVSS 3.0HIGH 8.1
  • TI-2024-34954 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string CVSS 3.1HIGH 7.5
  • TI-2024-27515 Apache Zeppelin: raft directory listing and file read CVSS 3.1HIGH 7.5
See all 25 →

Sources