Cross Site Scripting in markdown interpreter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting vulnerability in markdown interpreter of Apache Zeppelin allows an attacker to inject malicious scripts. This issue affects Apache Zeppelin Apache Zeppelin versions prior to 0.9.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Zeppelin | Apache Zeppelin to before 0.9.0 | 0.9.0 | Patch available | CNA |
| — | org.apache.zeppelin:zeppelin (Maven) | before 0.9.0 | 0.9.0 | Patch available | GHSA-mf7q-gw5f-q8jj |
- Apache Zeppelin VendorApache Affected Apache Zeppelin to before 0.9.0 Fixed in 0.9.0 Patch available CNA
- org.apache.zeppelin:zeppelin (Maven) Vendor— Affected before 0.9.0 Fixed in 0.9.0 Patch available GHSA-mf7q-gw5f-q8jj
Remediation
- Fix · CNA Apache Zeppelin (Apache Software Foundation) Fixed in 0.9.0
- Fix · GHSA-mf7q-gw5f-q8jj org.apache.zeppelin:zeppelin (Maven) Fixed in 0.9.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Apache Zeppelin — GLSA-202311-04
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2019-07420 bash command injection in spark interpreterPriority MEDIUM 51
- TI-2020-10907 Notebook permissions bypassPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27578
- 2026-10-03 Alias added: GHSA-mf7q-gw5f-q8jj
References
Advisory 4
Other 6
- [announce] 20210902 CVE-2021-27578: Apache Zeppelin: Cross Site Scripting in markdown interpreter
- [zeppelin-users] 20210928 Re: CVE-2021-27578: Apache Zeppelin: Cross Site Scripting in markdown interpreter
- https://github.com/apache/zeppelin
- https://lists.apache.org/thread.html/r31012f2c8e39a5e12e14c1de030012cb8b51c037d953d73b291b7b50@%3Cusers.zeppelin.apache.org%3E
- https://lists.apache.org/thread.html/r90590aa5ea788128ecc2e822e1e64d5200b4cb92b06707b38da4cb3d@%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/r90590aa5ea788128ecc2e822e1e64d5200b4cb92b06707b38da4cb3d@%3Cusers.zeppelin.apache.org%3E
More Apache Zeppelin vulnerabilities
- TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injection CVSS 3.1CRITICAL 9.8
- TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection string CVSS 3.1CRITICAL 9.8
- TI-2019-07420 bash command injection in spark interpreter CVSS 3.1CRITICAL 9.8
- TI-2018-01220 Improper authentication in Apache Zeppelin CVSS 3.0HIGH 8.8
- TI-2017-09344 Session fixation in Apache Zeppelin CVSS 3.0HIGH 8.1
- TI-2024-34954 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string CVSS 3.1HIGH 7.5
Sources
- CVE-2021-27578 · CVE Program
- CVE-2021-27578 · NVD
- FIRST EPSS
- GHSA-mf7q-gw5f-q8jj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences