Read the docs
TI-2019-07464 Aliases CVE-2019-10141GHSA-c7fc-cm7p-92r2

SQL injection in Red Hat openstack-ironic-inspector

Priority MEDIUM 44CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.

Summary

A vulnerability was found in openstack-ironic-inspector all versions excluding 5.0.2, 6.0.3, 7.2.4, 8.0.3 and 8.2.1. A SQL-injection vulnerability was found in openstack-ironic-inspector's node_cache.find_node(). This function makes a SQL query using unfiltered data from a server reporting inspection results (by a POST to the /v1/continue endpoint). Because the API is unauthenticated, the flaw could be exploited by an attacker with access to the network on which ironic-inspector is listening. Because of how ironic-inspector uses the query results, it is unlikely that data could be obtained. However, the attacker could pass malicious data and create a denial of service.

Why it matters now

EPSS 0.02533 85th percentileScored 2026-11-07
Fix Fixed ironic-inspector (PyPI): 5.0.2, 6.0.3, 7.2.4 +2Red Hat: 4 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red Hatopenstack-ironic-inspectorall 5.0.x up to, excluding 5.0.2; all 6.0.x up to, excluding 6.0.3; all 7.2.x up to, excluding 7.2.4; all 8.0.3 up to, excluding 8.0.3; 8.2.0—No fix listedCNA
—ironic-inspector (PyPI)before 5.0.25.0.2Patch availableGHSA-c7fc-cm7p-92r2
—ironic-inspector (PyPI)5.1.0 to before 6.0.36.0.3Patch availableGHSA-c7fc-cm7p-92r2
—ironic-inspector (PyPI)6.1.0 to before 7.2.47.2.4Patch availableGHSA-c7fc-cm7p-92r2
—ironic-inspector (PyPI)8.0.0 to before 8.0.38.0.3Patch availableGHSA-c7fc-cm7p-92r2
—ironic-inspector (PyPI)8.1.0 to before 8.2.18.2.1Patch availableGHSA-c7fc-cm7p-92r2
  • openstack-ironic-inspector VendorRed Hat Affected all 5.0.x up to, excluding 5.0.2; all 6.0.x up to, excluding 6.0.3; all 7.2.x up to, excluding 7.2.4; all 8.0.3 up to, excluding 8.0.3; 8.2.0 Fixed in — No fix listed CNA
  • ironic-inspector (PyPI) Vendor— Affected before 5.0.2 Fixed in 5.0.2 Patch available GHSA-c7fc-cm7p-92r2
  • ironic-inspector (PyPI) Vendor— Affected 5.1.0 to before 6.0.3 Fixed in 6.0.3 Patch available GHSA-c7fc-cm7p-92r2
  • ironic-inspector (PyPI) Vendor— Affected 6.1.0 to before 7.2.4 Fixed in 7.2.4 Patch available GHSA-c7fc-cm7p-92r2
  • ironic-inspector (PyPI) Vendor— Affected 8.0.0 to before 8.0.3 Fixed in 8.0.3 Patch available GHSA-c7fc-cm7p-92r2
  • ironic-inspector (PyPI) Vendor— Affected 8.1.0 to before 8.2.1 Fixed in 8.2.1 Patch available GHSA-c7fc-cm7p-92r2

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:openstack:ironic-inspector:*:*:*:*:*:*:*:*before 5.0.2; 5.1.0 to before 6.0.3; 6.1.0 to before 7.2.4; 8.0.0 to before 8.0.3; 8.1.0 to before 8.2.1VulnerableOpenStack
cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:*10VulnerableRed Hat
cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*13VulnerableRed Hat
cpe:2.3:a:redhat:openstack:14:*:*:*:*:*:*:*14VulnerableRed Hat
cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:*9VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*7.0Running onRed Hat
  • cpe:2.3:a:openstack:ironic-inspector:*:*:*:*:*:*:*:* Versions before 5.0.2; 5.1.0 to before 6.0.3; 6.1.0 to before 7.2.4; 8.0.0 to before 8.0.3; 8.1.0 to before 8.2.1 Vulnerable ·OpenStack
  • cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:* Versions 10 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:14:*:*:*:*:*:*:* Versions 14 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:* Versions 9 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat

Remediation

  • Fix · GHSA-c7fc-cm7p-92r2 ironic-inspector (PyPI) Fixed in 5.0.2 Advisory →
  • Fix · GHSA-c7fc-cm7p-92r2 ironic-inspector (PyPI) Fixed in 6.0.3 Advisory →
  • Fix · GHSA-c7fc-cm7p-92r2 ironic-inspector (PyPI) Fixed in 7.2.4 Advisory →
  • Fix · GHSA-c7fc-cm7p-92r2 ironic-inspector (PyPI) Fixed in 8.0.3 Advisory →
  • Fix · GHSA-c7fc-cm7p-92r2 ironic-inspector (PyPI) Fixed in 8.2.1 Advisory →

Red Hat 4 advisories

  • RHSA-2019:2505 Released 2019-08-15 · Red Hat rating Important
    openstack-ironic-inspector security update
    • OpenStack 9.0 Director for RHEL 7 openstack-ironic-inspector-3.2.2-5.el7ost, openstack-ironic-inspector-doc-3.2.2-5.el7ost
  • RHSA-2019:1734 Released 2019-07-10 · Red Hat rating Important
    openstack-ironic-inspector security update
    • Red Hat OpenStack Platform 13.0 openstack-ironic-inspector-7.2.3-3.el7ost
  • RHSA-2019:1722 Released 2019-07-10 · Red Hat rating Important
    openstack-ironic-inspector security update
    • Red Hat OpenStack Platform 10.0 openstack-ironic-inspector-4.2.2-6.el7ost
Show 1 more Red Hat advisories
  • RHSA-2019:1669 Released 2019-07-02 · Red Hat rating Important
    openstack-ironic-inspector security update
    • Red Hat OpenStack Platform 14.0 openstack-ironic-inspector-8.0.3-0.20190420013817.el7ost

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenStack 9.0 Director for RHEL 7Fixed RHSA-2019:2505
Red Hat OpenStack Platform 10.0Fixed RHSA-2019:1722
Red Hat OpenStack Platform 13.0Fixed RHSA-2019:1734
Red Hat OpenStack Platform 14.0Fixed RHSA-2019:1669
Not affected: 1 product
  • Red Hat OpenStack Platform 15 (Stein)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10141
  2. 2026-10-03 Alias added: GHSA-c7fc-cm7p-92r2

References

  • TI-2016-05707 Oracle MySQL through 5.5.52, 5.6.x through 5.6.33, and 5.7.x through 5.7.15; MariaDB… CVSS 3.0CRITICAL 9.8
  • TI-2018-07980 Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis… CVSS 3.0CRITICAL 9.8
  • TI-2020-07599 Apache HTTP Server versions 2.4.20 to 2.4.43. CVSS 3.1HIGH 7.5
  • TI-2019-06950 Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a… CVSS 3.1HIGH 7.5
  • TI-2018-15768 Memcached version 1.5.5 contains an Insufficient Control of Network Message Volume… CVSS 3.0HIGH 7.5
  • TI-2019-06949 Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a… CVSS 3.1HIGH 7.5
See all 209 →

Sources