Resource allocation without limits in PowerDNS pdns
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-770.
Summary
A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent any further updates to any slave zone by sending a large number of NOTIFY messages. Note that only servers configured as slaves are affected by this issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | pdns | fixed in 4.1.9; fixed in 4.0.8 | — | No fix listed | CNA |
- pdns VendorPowerDNS Affected fixed in 4.1.9; fixed in 4.0.8 Fixed in — No fix listed CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:powerdns:authoritative:*:*:*:*:*:*:*:* | 4.0.0 to before 4.0.8; 4.1.0 to before 4.1.9 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:authoritative:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | PowerDNS |
| cpe:2.3:o:opensuse:backports:sle-15:-:*:*:*:*:*:* | sle-15 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:* | sle-15 sp1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:powerdns:authoritative:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.8; 4.1.0 to before 4.1.9 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:authoritative:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·PowerDNS
- cpe:2.3:o:opensuse:backports:sle-15:-:*:*:*:*:*:* Versions sle-15 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:backports:sle-15:sp1:*:*:*:*:*:* Versions sle-15 sp1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
No fixed version listed by the sources yet.
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
PowerDNS pdns — openSUSE-SU-2019:1904
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-07483 Uncontrolled resource consumption in PowerDNS pdnsPriority LOW 36
- Advisory ·
PowerDNS pdns — openSUSE-SU-2019:1921
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-07483 Uncontrolled resource consumption in PowerDNS pdnsPriority LOW 36
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10163
- 2026-10-03 Alias added: GHSA-25qr-4mfj-987c
References
More PowerDNS Authoritative vulnerabilities
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2015-04466 PowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to… CVSS 2.0MEDIUM 5.0
- TI-2016-04702 PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a… CVSS 3.0HIGH 7.5
- TI-2026-25990 Incomplete domain name sanitization during CVSS 3.1CRITICAL 9.8
- TI-2020-15157 An issue was discovered in PowerDNS Authoritative through 4.3.0 when… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-10163 · CVE Program
- CVE-2019-10163 · NVD
- FIRST EPSS
- GHSA-25qr-4mfj-987c · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10163 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences