Insufficiently protected credentials in Jenkins InfluxDB Plugin
Priority MEDIUM 42CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins InfluxDB Plugin 1.21 and earlier stored credentials unencrypted in its global configuration file on the Jenkins master where they can be viewed by users with access to the master file system.
Why it matters now
EPSS 0.01746 77th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:influxdb (Maven): 1.22
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins InfluxDB Plugin | up to 1.21 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:influxdb (Maven) | before 1.22 | 1.22 | Patch available | GHSA-rv97-r8f7-8wmg |
- Jenkins InfluxDB Plugin VendorJenkins Affected up to 1.21 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:influxdb (Maven) Vendor— Affected before 1.22 Fixed in 1.22 Patch available GHSA-rv97-r8f7-8wmg
Remediation
- Fix · GHSA-rv97-r8f7-8wmg org.jenkins-ci.plugins:influxdb (Maven) Fixed in 1.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10329
- 2026-10-03 Alias added: GHSA-rv97-r8f7-8wmg
References
Advisory 3
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2019-10329 · CVE Program
- CVE-2019-10329 · NVD
- FIRST EPSS
- GHSA-rv97-r8f7-8wmg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences