Exposure of resource to wrong sphere in Jenkins Google Kubernetes Engine Plugin
Priority LOW 20CWE-668Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-668 and the CVSS impact.
Summary
Jenkins Google Kubernetes Engine Plugin 0.6.2 and earlier created a temporary file containing a temporary access token in the project workspace, where it could be accessed by users with Job/Read permission.
Why it matters now
EPSS 0.00344 28th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:google-kubernetes-engine (Maven): 0.6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Google Kubernetes Engine Plugin | up to 0.6.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:google-kubernetes-engine (Maven) | before 0.6.3 | 0.6.3 | Patch available | GHSA-xw4c-9434-3f7p |
- Jenkins Google Kubernetes Engine Plugin VendorJenkins Affected up to 0.6.2 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:google-kubernetes-engine (Maven) Vendor— Affected before 0.6.3 Fixed in 0.6.3 Patch available GHSA-xw4c-9434-3f7p
Remediation
- Fix · GHSA-xw4c-9434-3f7p org.jenkins-ci.plugins:google-kubernetes-engine (Maven) Fixed in 0.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10365
- 2026-10-03 Alias added: GHSA-xw4c-9434-3f7p
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2019-10365 · CVE Program
- CVE-2019-10365 · NVD
- FIRST EPSS
- GHSA-xw4c-9434-3f7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences