Cross-site scripting in Jenkins
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
A stored cross-site scripting vulnerability in Jenkins 2.191 and earlier, LTS 2.176.2 and earlier allowed attackers with Overall/Administer permission to configure the update site URL to inject arbitrary HTML and JavaScript in update center web pages.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | 2.191 and earlier, LTS 2.176.2 and earlier | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.176.3 | 2.176.3 | Patch available | GHSA-9m48-54pj-h248 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.177 to before 2.192 | 2.192 | Patch available | GHSA-9m48-54pj-h248 |
- Jenkins VendorJenkins Affected 2.191 and earlier, LTS 2.176.2 and earlier Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.176.3 Fixed in 2.176.3 Patch available GHSA-9m48-54pj-h248
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.177 to before 2.192 Fixed in 2.192 Patch available GHSA-9m48-54pj-h248
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* | up to 2.176.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* | up to 2.191 | Vulnerable | Jenkins |
| cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.9.0:*:*:*:*:*:*:* | 1.9.0 | Vulnerable | Oracle |
| cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* | 3.11 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Red Hat |
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.176.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 2.191 Vulnerable ·Jenkins
- cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.9.0:*:*:*:*:*:*:* Versions 1.9.0 Vulnerable ·Oracle
- cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-9m48-54pj-h248 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.176.3 Advisory →
- Fix · GHSA-9m48-54pj-h248 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.192 Advisory →
Red Hat 2 advisories
- RHSA-2019:3144 Released 2019-10-18 · Red Hat rating ImportantOpenShift Container Platform 3.11 jenkins security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2.176.3.1569349414-1.el7
- RHSA-2019:2789 Released 2019-09-20 · Red Hat rating ImportantOpenShift Container Platform 4.1.16 jenkins security update
- Red Hat OpenShift Container Platform 4.1 jenkins-2.176.3.1568229898-1.el7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — RHSA-2019:2789
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-07693 Cross-site request forgery in JenkinsPriority MEDIUM 41
- Advisory ·
Jenkins — RHSA-2019:3144
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-07693 Cross-site request forgery in JenkinsPriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:3144 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:2789 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10383
- 2026-10-03 Alias added: GHSA-9m48-54pj-h248
References
Advisory 5
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-10383 · CVE Program
- CVE-2019-10383 · NVD
- FIRST EPSS
- GHSA-9m48-54pj-h248 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10383 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences