Read the docs
TI-2019-07714 Aliases CVE-2019-10405GHSA-47wc-p5cp-w7pw

Cross-site scripting in Jenkins

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting, Information disclosure
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79 and CWE-200.

Summary

Jenkins 2.196 and earlier, LTS 2.176.3 and earlier printed the value of the "Cookie" HTTP request header on the /whoAmI/ URL, allowing attackers exploiting another XSS vulnerability to obtain the HTTP session cookie despite it being marked HttpOnly.

Why it matters now

EPSS 0.6529 99th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.176.4, 2.197Red Hat: 2 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins2.196 and earlier, LTS 2.176.3 and earlier—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.176.42.176.4Patch availableGHSA-47wc-p5cp-w7pw
—org.jenkins-ci.main:jenkins-core (Maven)2.177 to before 2.1972.197Patch availableGHSA-47wc-p5cp-w7pw
  • Jenkins VendorJenkins Affected 2.196 and earlier, LTS 2.176.3 and earlier Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.176.4 Fixed in 2.176.4 Patch available GHSA-47wc-p5cp-w7pw
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.177 to before 2.197 Fixed in 2.197 Patch available GHSA-47wc-p5cp-w7pw

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.176.3VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.196VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.176.3 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.196 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-47wc-p5cp-w7pw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.176.4 Advisory →
  • Fix · GHSA-47wc-p5cp-w7pw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.197 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.11Fixed—
Red Hat OpenShift Container Platform 4.3Fixed—
Not affected: 2 products
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10405
  2. 2026-10-03 Alias added: GHSA-47wc-p5cp-w7pw

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources