Improper certificate validation in Jenkins Bumblebee HP ALM Plugin
Priority LOW 30CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Jenkins Bumblebee HP ALM Plugin 4.1.3 and earlier unconditionally disabled SSL/TLS and hostname verification for connections to HP ALM.
Why it matters now
EPSS 0.00799 56th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:bumblebee (Maven): 4.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Bumblebee HP ALM Plugin | up to 4.1.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:bumblebee (Maven) | before 4.1.4 | 4.1.4 | Patch available | GHSA-qgp8-h5cp-r75r |
- Jenkins Bumblebee HP ALM Plugin VendorJenkins Affected up to 4.1.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:bumblebee (Maven) Vendor— Affected before 4.1.4 Fixed in 4.1.4 Patch available GHSA-qgp8-h5cp-r75r
Remediation
- Fix · GHSA-qgp8-h5cp-r75r org.jenkins-ci.plugins:bumblebee (Maven) Fixed in 4.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10444
- 2026-10-03 Alias added: GHSA-qgp8-h5cp-r75r
References
More Jenkins Bumblebee Hp Alm vulnerabilities
- TI-2021-04694 Insufficiently protected credentials in Jenkins Bumblebee HP ALM Plugin CVSS 3.1MEDIUM 5.5
Sources
- CVE-2019-10444 · CVE Program
- CVE-2019-10444 · NVD
- FIRST EPSS
- GHSA-qgp8-h5cp-r75r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences