Insufficiently protected credentials in Jenkins Bumblebee HP ALM Plugin
Priority LOW 25CWE-522Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Bumblebee HP ALM Plugin 4.1.5 and earlier stores credentials unencrypted in its global configuration file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.
Why it matters now
EPSS 0.00335 27th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:bumblebee (Maven): 4.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Bumblebee HP ALM Plugin | up to 4.1.5 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:bumblebee (Maven) | before 4.1.6 | 4.1.6 | Patch available | GHSA-8v72-qr3h-c6rv |
- Jenkins Bumblebee HP ALM Plugin VendorJenkins Affected up to 4.1.5 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:bumblebee (Maven) Vendor— Affected before 4.1.6 Fixed in 4.1.6 Patch available GHSA-8v72-qr3h-c6rv
Remediation
- Fix · GHSA-8v72-qr3h-c6rv org.jenkins-ci.plugins:bumblebee (Maven) Fixed in 4.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21614
- 2026-10-03 Alias added: GHSA-8v72-qr3h-c6rv
References
More Jenkins Bumblebee Hp Alm vulnerabilities
- TI-2019-07753 Improper certificate validation in Jenkins Bumblebee HP ALM Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-21614 · CVE Program
- CVE-2021-21614 · NVD
- FIRST EPSS
- GHSA-8v72-qr3h-c6rv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences