Insufficiently protected credentials in Jenkins Dynatrace Application Monitoring Plugin
Priority LOW 34CWE-522Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Dynatrace Application Monitoring Plugin 2.1.3 and earlier stored credentials unencrypted in its global configuration file on the Jenkins master where they could be viewed by users with access to the master file system.
Why it matters now
EPSS 0.00333 26th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:dynatrace-dashboard (Maven): 2.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Dynatrace Application Monitoring Plugin | up to 2.1.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:dynatrace-dashboard (Maven) | before 2.1.4 | 2.1.4 | Patch available | GHSA-6xw9-qq9h-cr68 |
- Jenkins Dynatrace Application Monitoring Plugin VendorJenkins Affected up to 2.1.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:dynatrace-dashboard (Maven) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-6xw9-qq9h-cr68
Remediation
- Fix · GHSA-6xw9-qq9h-cr68 org.jenkins-ci.plugins:dynatrace-dashboard (Maven) Fixed in 2.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10461
- 2026-10-03 Alias added: GHSA-6xw9-qq9h-cr68
References
More Jenkins Dynatrace Application Monitoring vulnerabilities
- TI-2019-07771 Cross-site request forgery in Jenkins Dynatrace Application Monitoring Plugin CVSS 3.1HIGH 8.1
- TI-2019-07772 Incorrect default permissions in Jenkins Dynatrace Application Monitoring Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-10461 · CVE Program
- CVE-2019-10461 · NVD
- FIRST EPSS
- GHSA-6xw9-qq9h-cr68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences