Cross-site request forgery in Jenkins Dynatrace Application Monitoring Plugin
Priority LOW 36CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery vulnerability in Jenkins Dynatrace Application Monitoring Plugin 2.1.3 and earlier allowed attackers to connect to an attacker-specified URL using attacker-specified credentials.
Why it matters now
EPSS 0.007 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:dynatrace-dashboard (Maven): 2.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Dynatrace Application Monitoring Plugin | up to 2.1.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:dynatrace-dashboard (Maven) | before 2.1.4 | 2.1.4 | Patch available | GHSA-x546-xrx3-hjx4 |
- Jenkins Dynatrace Application Monitoring Plugin VendorJenkins Affected up to 2.1.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:dynatrace-dashboard (Maven) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-x546-xrx3-hjx4
Remediation
- Fix · GHSA-x546-xrx3-hjx4 org.jenkins-ci.plugins:dynatrace-dashboard (Maven) Fixed in 2.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10462
- 2026-10-03 Alias added: GHSA-x546-xrx3-hjx4
References
Advisory 2
More Jenkins Dynatrace Application Monitoring vulnerabilities
- TI-2019-07770 Insufficiently protected credentials in Jenkins Dynatrace Application Monitoring Plugin CVSS 3.1HIGH 7.8
- TI-2019-07772 Incorrect default permissions in Jenkins Dynatrace Application Monitoring Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-10462 · CVE Program
- CVE-2019-10462 · NVD
- FIRST EPSS
- GHSA-x546-xrx3-hjx4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences