Incorrect default permissions in Jenkins Libvirt Slaves Plugin
Priority LOW 30CWE-276Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A missing permission check in Jenkins Libvirt Slaves Plugin allows attackers with Overall/Read permission to connect to an attacker-specified SSH server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Why it matters now
EPSS 0.00836 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:libvirt-slave (Maven): 1.8.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Libvirt Slaves Plugin | up to 1.8.5 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:libvirt-slave (Maven) | before 1.8.6 | 1.8.6 | Patch available | GHSA-m36j-f2hf-qgj2 |
- Jenkins Libvirt Slaves Plugin VendorJenkins Affected up to 1.8.5 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:libvirt-slave (Maven) Vendor— Affected before 1.8.6 Fixed in 1.8.6 Patch available GHSA-m36j-f2hf-qgj2
Remediation
- Fix · GHSA-m36j-f2hf-qgj2 org.jenkins-ci.plugins:libvirt-slave (Maven) Fixed in 1.8.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10472
- 2026-10-03 Alias added: GHSA-m36j-f2hf-qgj2
References
Advisory 2
Other 5
- https://jenkins.io/security/advisory/2019-10-23/#SECURITY-1014%20%281%29
- https://github.com/jenkinsci/libvirt-slave-plugin/commit/231c41e0e4ecb2d25247cc2775e1fe18d64a1703
- https://github.com/jenkinsci/libvirt-slave-plugin/commit/c671d68f9498414a735913c9372ede8b4791bfee
- https://github.com/jenkinsci/libvirt-slave-plugin
- https://jenkins.io/security/advisory/2019-10-23/#SECURITY-1014%20(1)
More Jenkins Libvirt Slaves vulnerabilities
- TI-2019-07780 Cross-site request forgery in Jenkins Libvirt Slaves Plugin CVSS 3.1HIGH 8.8
- TI-2019-07782 Incorrect default permissions in Jenkins Libvirt Slaves Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2019-10472 · CVE Program
- CVE-2019-10472 · NVD
- FIRST EPSS
- GHSA-m36j-f2hf-qgj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences