Incorrect default permissions in Jenkins Libvirt Slaves Plugin
Priority LOW 21CWE-276Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A missing permission check in Jenkins Libvirt Slaves Plugin in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.
Why it matters now
EPSS 0.00678 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:libvirt-slave (Maven): 1.8.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Libvirt Slaves Plugin | up to 1.8.5 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:libvirt-slave (Maven) | before 1.8.6 | 1.8.6 | Patch available | GHSA-8j3m-j6x6-cp5v |
- Jenkins Libvirt Slaves Plugin VendorJenkins Affected up to 1.8.5 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:libvirt-slave (Maven) Vendor— Affected before 1.8.6 Fixed in 1.8.6 Patch available GHSA-8j3m-j6x6-cp5v
Remediation
- Fix · GHSA-8j3m-j6x6-cp5v org.jenkins-ci.plugins:libvirt-slave (Maven) Fixed in 1.8.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10473
- 2026-10-03 Alias added: GHSA-8j3m-j6x6-cp5v
References
Advisory 2
Other 5
- https://jenkins.io/security/advisory/2019-10-23/#SECURITY-1014%20%282%29
- https://github.com/jenkinsci/libvirt-slave-plugin/commit/c671d68f9498414a735913c9372ede8b4791bfee
- https://github.com/jenkinsci/libvirt-slave-plugin
- https://github.com/jenkinsci/libvirt-slave-plugin/releases
- https://jenkins.io/security/advisory/2019-10-23/#SECURITY-1014%20(2)
More Jenkins Libvirt Slaves vulnerabilities
- TI-2019-07780 Cross-site request forgery in Jenkins Libvirt Slaves Plugin CVSS 3.1HIGH 8.8
- TI-2019-07781 Incorrect default permissions in Jenkins Libvirt Slaves Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-10473 · CVE Program
- CVE-2019-10473 · NVD
- FIRST EPSS
- GHSA-8j3m-j6x6-cp5v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences