Read the docs
TI-2019-07982 Aliases CVE-2019-10694GHSA-8h2m-rx7g-r9gv

Hard-coded credentials in Puppet Enterprise

Priority MEDIUM 44CWE-798Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-798.

Summary

The express install, which is the suggested way to install Puppet Enterprise, gives the user a URL at the end of the install to set the admin password. If they do not use that URL, there is an overlooked default password for the admin user. This was resolved in Puppet Enterprise 2019.0.3 and 2018.1.9.

Why it matters now

EPSS 0.01089 65th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Puppet EnterprisePuppet Enterprise 2019.x prior to 2019.0.3, Puppet Enterprise 2018.x prior to 2018.1.9—No fix listedCNA
  • Puppet Enterprise Vendor— Affected Puppet Enterprise 2019.x prior to 2019.0.3, Puppet Enterprise 2018.x prior to 2018.1.9 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:*2018.1.0 to before 2018.1.9; 2019.0 to before 2019.0.3VulnerablePuppet
  • cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions 2018.1.0 to before 2018.1.9; 2019.0 to before 2019.0.3 Vulnerable ·Puppet

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10694
  2. 2026-10-03 Alias added: GHSA-8h2m-rx7g-r9gv

References

  • TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
  • TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
  • TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
  • TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
See all 88 →

Sources