Open Redirector in spring-security-oauth2
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
Spring Security OAuth versions 2.3 prior to 2.3.6, 2.2 prior to 2.2.5, 2.1 prior to 2.1.5, and 2.0 prior to 2.0.18, as well as older unsupported versions could be susceptible to an open redirector attack that can leak an authorization code. A malicious user or attacker can craft a request to the authorization endpoint using the authorization code grant type, and specify a manipulated redirection URI via the redirect_uri parameter. This can cause the authorization server to redirect the resource owner user-agent to a URI under the control of the attacker with the leaked authorization code.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Security OAuth | 2.2 to before v2.2.5.RELEASE; 2.1 to before v2.1.5.RELEASE; 2.0 to before v2.0.18.RELEASE; 2.3 to before v2.3.6.RELEASE | v2.2.5.RELEASE, v2.1.5.RELEASE, v2.0.18.RELEASE, v2.3.6.RELEASE | Patch available | CNA |
| — | org.springframework.security.oauth:spring-security-oauth (Maven) | 2.0.0.RELEASE to before 2.0.18.RELEASE | 2.0.18.RELEASE | Patch available | GHSA-mmf6-6597-3v6m |
| — | org.springframework.security.oauth:spring-security-oauth (Maven) | 2.1.0.RELEASE to before 2.1.5.RELEASE | 2.1.5.RELEASE | Patch available | GHSA-mmf6-6597-3v6m |
| — | org.springframework.security.oauth:spring-security-oauth (Maven) | 2.2.0.RELEASE to before 2.2.5.RELEASE | 2.2.5.RELEASE | Patch available | GHSA-mmf6-6597-3v6m |
| — | org.springframework.security.oauth:spring-security-oauth (Maven) | 2.3.0.RELEASE to before 2.3.6.RELEASE | 2.3.6.RELEASE | Patch available | GHSA-mmf6-6597-3v6m |
- Spring Security OAuth VendorVMware Affected 2.2 to before v2.2.5.RELEASE; 2.1 to before v2.1.5.RELEASE; 2.0 to before v2.0.18.RELEASE; 2.3 to before v2.3.6.RELEASE Fixed in v2.2.5.RELEASE, v2.1.5.RELEASE, v2.0.18.RELEASE, v2.3.6.RELEASE Patch available CNA
- org.springframework.security.oauth:spring-security-oauth (Maven) Vendor— Affected 2.0.0.RELEASE to before 2.0.18.RELEASE Fixed in 2.0.18.RELEASE Patch available GHSA-mmf6-6597-3v6m
- org.springframework.security.oauth:spring-security-oauth (Maven) Vendor— Affected 2.1.0.RELEASE to before 2.1.5.RELEASE Fixed in 2.1.5.RELEASE Patch available GHSA-mmf6-6597-3v6m
- org.springframework.security.oauth:spring-security-oauth (Maven) Vendor— Affected 2.2.0.RELEASE to before 2.2.5.RELEASE Fixed in 2.2.5.RELEASE Patch available GHSA-mmf6-6597-3v6m
- org.springframework.security.oauth:spring-security-oauth (Maven) Vendor— Affected 2.3.0.RELEASE to before 2.3.6.RELEASE Fixed in 2.3.6.RELEASE Patch available GHSA-mmf6-6597-3v6m
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:spring_security_oauth:*:*:*:*:*:*:*:* | 2.0.0 to before 2.0.18; 2.1.0 to before 2.1.5; 2.2.0 to before 2.2.5; 2.3.0 to before 2.3.6 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:oracle:banking_corporate_lending:14.1.0:*:*:*:*:*:*:* | 14.1.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_corporate_lending:14.3.0:*:*:*:*:*:*:* | 14.3.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_corporate_lending:14.4.0:*:*:*:*:*:*:* | 14.4.0 | Vulnerable | Oracle |
- cpe:2.3:a:pivotal_software:spring_security_oauth:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.18; 2.1.0 to before 2.1.5; 2.2.0 to before 2.2.5; 2.3.0 to before 2.3.6 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:oracle:banking_corporate_lending:14.1.0:*:*:*:*:*:*:* Versions 14.1.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_corporate_lending:14.3.0:*:*:*:*:*:*:* Versions 14.3.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_corporate_lending:14.4.0:*:*:*:*:*:*:* Versions 14.4.0 Vulnerable ·Oracle
Remediation
- Fix · CNA Spring Security OAuth (Spring) Fixed in v2.2.5.RELEASE, v2.1.5.RELEASE, v2.0.18.RELEASE, v2.3.6.RELEASE
- Fix · GHSA-mmf6-6597-3v6m org.springframework.security.oauth:spring-security-oauth (Maven) Fixed in 2.0.18.RELEASE Advisory →
- Fix · GHSA-mmf6-6597-3v6m org.springframework.security.oauth:spring-security-oauth (Maven) Fixed in 2.1.5.RELEASE Advisory →
- Fix · GHSA-mmf6-6597-3v6m org.springframework.security.oauth:spring-security-oauth (Maven) Fixed in 2.2.5.RELEASE Advisory →
- Fix · GHSA-mmf6-6597-3v6m org.springframework.security.oauth:spring-security-oauth (Maven) Fixed in 2.3.6.RELEASE Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11269
- 2026-10-03 Alias added: GHSA-mmf6-6597-3v6m
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-11269 · CVE Program
- CVE-2019-11269 · NVD
- FIRST EPSS
- GHSA-mmf6-6597-3v6m · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11269 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences