RabbitMQ XSS attack
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-79.
Summary
Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | RabbitMQ | before v3.7.18 | v3.7.18 | Patch available | CNA |
| Pivotal | RabbitMQ for PCF | 1.15 to before 1.15.13; 11.16 to before 1.16.6; 1.17 to before 1.17.3 | 1.15.13, 1.16.6, 1.17.3 | Patch available | CNA |
- RabbitMQ VendorPivotal Affected before v3.7.18 Fixed in v3.7.18 Patch available CNA
- RabbitMQ for PCF VendorPivotal Affected 1.15 to before 1.15.13; 11.16 to before 1.16.6; 1.17 to before 1.17.3 Fixed in 1.15.13, 1.16.6, 1.17.3 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* | before 3.7.18 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* | 1.15.0 to before 1.15.13; 1.16.0 to before 1.16.6; 1.17.0 to before 1.17.3 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* | 15 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack_for_ibm_power:15:*:*:*:*:*:*:* | 15 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
- cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* Versions before 3.7.18 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* Versions 1.15.0 to before 1.15.13; 1.16.0 to before 1.16.6; 1.17.0 to before 1.17.3 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack_for_ibm_power:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA RabbitMQ (Pivotal) Fixed in v3.7.18
- Fix · CNA RabbitMQ for PCF (Pivotal) Fixed in 1.15.13, 1.16.6, 1.17.3
Red Hat 1 advisory
- RHSA-2020:0078 Released 2020-01-13 · Red Hat rating Importantrabbitmq-server security update
- Red Hat OpenStack Platform 15.0 rabbitmq-server-3.7.22-1.el8ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 14 (Rocky) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 15.0 | Fixed | RHSA-2020:0078 |
Not affected: 2 products
- CloudForms Management Engine 5
- Red Hat Ansible Tower 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11281
- 2026-10-03 Alias added: GHSA-8v5q-8hwh-h2x8
References
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-11281 · CVE Program
- CVE-2019-11281 · NVD
- FIRST EPSS
- GHSA-8v5q-8hwh-h2x8 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11281 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences